Блог

Почистить Windows от всех сохранных паролей

запуск от имени администратор cmd

прописать rundll32.exe keymgr.dll, KRShowKeyMgr

Либо запускаем сontrol userpasswords2 от администратора, далее дополнительно, управление паролями, далее чистим, удаляем все что вам нужно.

Запрет автоматического подключения сетевых принтеров в win 10

Был поражен когда при первоначальной установки win 10 ОС добавила десяток сетевых принтеров в свежую систему. С такими приколами надо бороться…

Лечится это двумя способами. Для Win 10 Pro и выше версий правильно отключить в GPO:

gpedit.msc -> Computer Configuration -> Administrative Templates -> Printers 
Edit: «Add Printer wizard — Network scan page (Managed network)» 
Select «Disabled» 
Click «OK» 

В русской версии:

gpedit.msc -> Конфигурация компьютера -> Административные шаблоны-> Принтеры
Выбрать и изменить Мастер установки принтеров
Выбрать «Отключено» и нажать «OK»

Для домашней версии подойдет правка реестра:

Windows Registry Editor Version 5.00 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\NcdAutoSetup\Private] 
«AutoSetup»=dword:00000000 

mRemoteNG

Давно искал программу для создания списка разнородных подключений серверов, таки нашел mRemoteNG.

Отлично себя показывает, имеет поддержку протоколов vnc, rdp, ssh

Оснастки windows

Возникает куча ситуаций когда требуется запустить административные оснастки Windows.

А названия как назло нужной оснастки забыл, вот решил собрать список в кои веки и опубликовать на память.


Административные оснастки
Active Directory Пользователи и компьютеры (AD Users and Computers) dsa.msc
Диспетчер служб терминалов (Terminal Services Manager) tsadmin.msc
Управление компьютером (Computer Management) compmgmt.msc
Консоль управления GPO (Group Policy Management Console) gpmc.msc
Редактор объектов локальной политики (Group Policy Object Editor) gpedit.msc
Результирующая политика (результат применения политик) rsop.msc
Локальные параметры безопасности secpol.msc
Настройка терминального сервера (TS Configuration) tscc.msc
Маршрутизация и удаленый доступ (Routing and Remote Access) rrasmgmt.msc
Службы (Services) services.msc
Общие папки (Shared Folders) fsmgmt.msc
Диспетчер устройств (Device Manager) devmgmt.msc
Локальные пользователи и группы (Local users and Groups) lusrmgr.msc
Локальная политика безопасности(Local Security Settings) secpol.msc
Управление дисками (Disk Management) diskmgmt.msc
Active Directory Домены и Доверие(AD Domains and Trusts) domain.msc
Active Directory Сайты и Доверие (AD Sites and Trusts) dssite.msc
Политика безопасности домена (Domain Security Settings) dompol.msc
Политика безопасности контроллера домена (DC Security Settings) dсpol.msc
Распределенная файловая система DFS (Distributed File System) dfsgui.msc

Запуск оснасток панели управления

Название элемента панели управления
Свойства системы sysdm.cpl
Установка и удаление программ appwiz.cpl
Учетные записи пользователей nusrmgr.cpl
Дата и время timedate.cpl
Свойства экрана desk.cpl
Брэндмауэр Windows firewall.cpl
Мастер установки оборудования hdwwiz.cpl
Свойства Интернет inetcpl.cpl
Специальные возможности access.cpl
Свойства мыши control Main.cpl
Свойства клавиатуры control Main.cpl,@1
Язык и региональные возможности intl.cpl
Игровые устройства joy.cpl
Свойства: Звуки и аудиоустройства mmsys.cpl
Мастер настройки сети netsetup.cpl
Управление электропитанием powercfg.cpl
Центр обеспечения безопасности wscui.cpl
Автоматическое обновление wuaucpl.cpl
Сетевые подключения ncpa.cpl


Все это добро удобно запускать от администратора через cmd. Запускаете командную строку от админа и все вы сможете все оснастки запускать с правами администратора

Настройка EthOverUsb EUO Атол

Перейдите в директорию, в которую вы установили драйвера ДТО. По умолчанию, это «C:\Program Files\ATOL»,
Перейдите в папку «EthOverUsb». Создайте в ней два пустых файла – «settings.xml» и «USE_LOCAL_CONFIGS»,
Откройте файл «settings.xml» в текстовом редакторе WordPad и добавьте туда следующие строчки:

<?xml version="1.0" encoding="windows-1251" ?>
<settings>
<device>
<id>1</id>
<port>4</port>
</device>
</settings>

В укажите номер порта atol-usbcom_proxy, по которому нет связи с кассой и сохраните изменения,
Откройте «Диспетчер задач» Windows, перейдите на вкладку «Службы» и найдите в списке службу EoU. Нажмите на неё правой
кнопкой мыши и выберите «Перезапустить». Убедитесь, что состояние службы после перезапуска – «Выполняется»,
Запустите «EthOverUsb.exe» из командной строки от имени администратора с ключом -e. Если вы указали правильный порт в
файле «settings.xml», вы увидите в логах «Opening COM… OK». В противном случае вы увидите «Opening COM… Отказано в
доступе»

Перерегистрация фискального регистратора ШТРИХ-ЛАЙТ-02Ф модернизированного

Возникла проблема у клиента. Классическая схема.
Закончился срок работы фн, ко всему прочему доблестные продавцы накануне забыли снять z-отчет за отработанную смену.
На следующее утро кассовую смену не смогли ни открыть, ни закрыть. В течении суток они самостоятельно пытались восстановить работоспособность кассы, После чего притащили ее к нам, а хозяин фискального регистратора заявил что ситуация простая, нужно всего лишь сменить дату и время на предыдущие сутки.
Пациент в этот раз оказался ФР ШТРИХ-ЛАЙТ-02Ф.
Исправить проблему на кассе драйвером уже нельзя, так как при открытой смене нельзя менять время, а снять z-отчет не давает переполненный ФН.
Внимание!!! Впервую очередь в тесте драйвера делаем экспорт таблиц. Иначе после тех. обнуления все просрется без возможности восстановления.
Далее вскрываем корпус
Внутри прикреплен УМКа (комплект устройства модернизации).
Снимаем у УМК пластиковый корпус, находим батарейку. Рядом с батарейкой, есть джампер. Снимаем перемычку, ждем минутку. Вставляем джампер назад. Подключаем к ПК, в драйвере видим ошибку ОЗУ. Заходим в сервис, нажимаем на тех обнуление, далее выставляем время последнего кассового документа на ФР. Если мы сразу попытаемся закрыть фискальный режим, скорее всего выпадет ошибка типа неверное состояние фискального накопителя. Все из-за того что у кассового аппарата смена закрыта, а у фн открыта. Пробуем открыть новую смену с теста драйвера. Смена открывается и тут же
закрываем смену сняв зет-отчет. Ждем отправки последнего документа ОФД. Далее проводим закрытие фискального накопителя. Подключаем ккт к компьютеру, заливаем назад таблицы в кассу, убеждаемся что все данные в ОФД ушли,
После этого меняем фн и регистрируем кассу как обычно при смене ФН.

mikrotik перенаправление dns для определенного домена

При организации единой корпоративной сети, и филиалов встает вопрос работы компьютеров в домене, как заставить резолвить DNS имена головного офиса компьютерами филиалов.

Существует несколько способов решения этой задачи.

Во первых вы можете поднять днс сервер и синхронизировать его с KD головного офиса. В принципе отличное решение вопроса, но чаще всего бывает что лишний компьютер никто выделять не станет, да и администрировать его тоже будет некогда, особенно если филиалов много.

В случае если стоят микротики можно настроить пересылку dns-запросов для определенного домена на dns головного офиса (Conditional DNS forwarding).

Итак задача: все днс-запросы mydomen для микротика 172.16.10.1 перенаправить на сервер 192.168.0.100
Реализуется это в firewall на уровне 7 (Layer7 Protocols).

задаем выражение для поиска в запросах

/ip firewall layer7-protocol add name=mydomain regexp=domain

Помечаем нужный трафик

/ip firewall mangle add chain=prerouting dst-address=172.16.10.1 layer7-protocol=mydomain action=mark-connection new-connection-mark=mydomen-dns protocol=udp dst-port=53 

Далее перенаправляем помеченный трафик на нужный нам сервер

/ip firewall nat add action=dst-nat chain=dstnat connection-mark=domain-dns to-addresses=192.168.0.100

Эти три правила будут работать в том случае если уже установлено соединение и настроена маршрутизация, в ином случае нужно настраивать маршрутизацию.Но это уже другая история.

Для того чтоб перенаправлять все днс запросы с устройств на микротик достаточно такого правила

ip firewall nat add action=dst-nat chain=dstnat disabled=yes dst-port=53 protocol=udp src-address=172.16.10.0/24 to-addresses=172.16.10.1 to-ports=53